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Overview of X10MSW
X10MSW, is a MS-Windows application which allows you to control lights, appliances, etc. 
around your home from your PC.    X10MSW is meant to be used with the CP290 
"Powerhouse" computer interface manufactured by X-10 USA, although there is a demo 
mode which does not require a    CP290.    The CP290 attaches to your PC via a serial cable, 
and works with other X-10 devices (called units) to control lights, appliances, etc. around 
your home.    With X10MSW, you can send "direct" commands to turn things on, off, or, in 
the case of lights, dim or brighten them.    You can also download a set of events into the 
CP290's battery backed-up memory for execution at some preset time/day.    Once the 
CP290 has a set of events in its memory, you can turn the PC off and the CP290 will 
continue to execute those events.    Events are anything you can do with "direct" 
commands such as on, off, dim, etc., but you tell the CP290 when to do the command.
X10MSW also supports the PLIX evaluation board from Micromint Inc. which allows you to 
use a standard parallel printer port (LPT1-3) with a TW523 bi-directional powerline interface
from X10 USA.    This allows you to monitor all X10 events and to do bright commands.    
See PLIX for contact information on Micromint Inc.
X10MSW allows you to define a set of icons which represent the various X-10 units you 
have around your home.    X10MSW has icons for lamps, generic appliances, fans, radios; or
you can customize each X-10 unit with your own icons (which you must first build using any
icon editor).    You give each unit a location and a description which are used throughout 
X10MSW.    You use these icons to control the units from your PC.
Once you have defined your units, you can create windows which display a bit map of the 
various rooms in your home and place the units in those windows.    Imagine "walking" 
around your home (by moving between windows), turning lamps, appliances, etc. on an off;
all without having to leave the chair in front of your PC!    The betimes of your rooms are 
created outside of X10MSW, and help put you in control of your home.
X10MSW allows you to create and save multiple files which contain CP290 events.    
X10MSW also allows you to monitor the commands being sent by the CP290, or with the 
optional PLIX interface monitor all X10 commands.    It does all this using MS-Windows 
Multiple Document Interface (MDI) which allows several windows within the one X10MSW 
main window.
X10MSW events are fairly sophisticated, consisting of a command such as on, off, dim, 
bright, etc.;    the X-10 unit or units which are to be affected; a time of day including 
sunrise, sunset, or plus/minus offset from them; a day of the week; and a month of the 
year.    Each event can be frozen - meaning it will not occur until you thaw it; or it can be 
qualified to only occur when you are on vacation (you have to tell X10MSW you are going 
on vacation); or it can be qualified by any of 8 conditions which you define (like guests in 
your home), and set or reset.
X10MSW events may also be defined to happen "now", allowing you to build up event files 
which do a bunch of direct commands.    If you start X10MSW, giving the name of an event 
file with only "now" events, they will be done automatically and X10MSW will exit after all 
direct commands are done.    This allows you to define a series of event files which can put 
your home into different "modes" (sometimes called "scenes") simply by double clicking on 
that event file.



Installation
X10MSW comes with a Windows-based installation program called install.exe.    This will 
unpack the X10MSW files into a default directory (C:\X10MSW), or into any directory you 
choose, and set up a Program Manager group for X10MSW.    Once the files are unpacked, a 
configuration program is run which does the following:

Creates a x10.ini file if one doesn't exist
Creates an association between event files (.x10) and X10MSW
Allows you to select the COM port to which the CP290 is attached
Allows you to select your latitude/longitude for sunrise/sunset calculations
Allows you enable automatic downloads of an event file at regular intervals

The association between event files (those with an extension of .x10) and X10MSW allows 
you to double click on an event file to launch X10MSW and have it open the event file in an 
event window, or if it contains only "now" commands they will be executed and X10MSW 
will exit..
Procedures Associated with Installation

Choosing a COM port
Choosing a Latitude/Longitude
Enabling Automatic Downloads

X10MSW uses the current MS-Windows colors for things like title bars, backgrounds, text, 
etc.    If you change the MS-Windows colors via the control panel, X10MSW will change its 
colors accordingly.



Choosing a COM port (Installation)

Select the com port to which the CP290 is connected and click on OK.
If a x10.ini exists in the Windows directory, the com port from the .ini file is used to select a
default port.    You can also choose demo mode to try some of X10MSW's features without 
having a CP290 attached.
The configuration program does not verify that a CP290 is indeed attached to the com port 
which you selected.    When X10MSW is started, it will check for a CP290 at the port you 
selected.    You can also change the com port selection in X10MSW by using the Interface 
menu.
See also
Selecting COM Ports
Selecting Demo Mode
Interface Menu



Choosing a Latitude/Longitude (Installation)
X10MSW needs your latitude and longitude to calculate sunrise and sunset event times.    
X10MSW comes with a small "database" of cities-lat/long pairs (latlong.dat) which is read 
into a list box.
1 Scroll through the list box, looking for the state/city in which you live (or to which you are

closest).    Or, (as with most list boxes), you can type the first letter of your state to 
"jump" to the first entry for your state.    Once you have located a state/city which 
matches your latitude/longitude, double-click on the item to copy the latitude/longitude 
to the edit boxes below the list box.

2 If a state/city pair with your latitude/longitude does not exist, you can enter your latitude 
and longitude directly into the edit boxes below the list box

3  Click on OK to select the latitude/longitude which is in the edit boxes..    If you entered an
illegal value, a error message will appear;    simply correct the value(s) and click OK 
again.

You can change your latitude and longitude in X10MSW by using the Options menu in any 
event window.
See also
Setting Latitude/Longitude.
Options Menu - Event Windows



Enabling Automatic Downloading
Automatic downloading allows you to keep your CP290 events accurate (up to date with the
correct sunrise and sunset times) by initiating downloads at regular intervals.
You configure auto download by specifying an event file and an interval (in days)    via the 
procedures described below.    Then, during start-up, if the time elapsed since your last 
download is larger than the interval you configured, you will be asked if you want to 
automatically start a download of the event file you specified.
In addition, the AutoX10.EXE application can be added to your Window's Startup program 
group and, if the time elapsed since the last download exceeds the interval you configured,
it will ask if you want to run X10MSW to initiate the download.    When X10MSW is started in
this way, it will not ask again about doing the auto download.    This way, every time you 
start Windows, AutoX10 will make a (very) quick check to see if its time to do a download.
If you don't want to bother doing it right now, you can say "no", and do it later (X10MSW 
will still detect the need for an auto download when it starts), or wait until the next time 
you start windows.
If you start X10MSW with a command file, and the auto download interval has elapsed, 
both files will be downloaded, and X10MSW will exit just like it does with command files.
To Enable Auto download:
You can enable auto download either during installation or via the Autodownload item in 
the Interface menu, or both.    The dialog used to enable automatic downloading looks like 
the regular "open file" dialog - you use this to specify the name of the event file you wish to
automatically download.    The dialog has an extra box in the bottom right corner where you
specify the number of days between downloads.    Use a value of 0 to disable auto 
downloading.
During install, if you choose to enable auto downloading, the AutoX10.EXE application will 
be added to your Startup program group.    AutoX10 takes a single argument - the name of 
the application to start to do the auto download.    If AutoX10 finds the interval since the 
last download exceeds that which you configured, it will ask if an auto download should be 
started, and if so it will start the application with the name of the event file you specified 
for auto download.
See also
Downloading Events



Getting Started
You will probably want to do the following the first time you start X10MSW:
1 Set the CP290 Base Housecode and Time

If you were using the CP290 before, chances are you have its base housecode and time 
already set.    If not, you can use the Interface menu item to set the base housecode (for
the keys on the CP290) and the time.
See also
Changing Base Housecode
Setting the Clock

2 Look at the sample.x10 event file
To see examples of some complicated events, you can open the sample.x10 event file by
double clicking on the sample item in the X10MSW Program Group, or by using the Open 
item in the File Menu.    Note that when you open an event file by using the File menu 
you can tell X10MSW to remember a particular directory.    All file operations (open, save, 
etc.) will start in that directory from then on, including after you have exited and re-
started X10MSW.    In general, you should not change X10MSW's data directory 
frequently, since it can cause the blueprint data file to be lost.
See also
All about Events
Opening an Event file

3 Define the units in your home
The sample x10.ini file included with X10MSW and set up during installation contains 
some sample units.    You should use the Units child window to add/change/delete the 
units so they match those defined in your home.    If you want to define your own unit 
types and use icons you have created for those types, you can do this when adding or 
changing units.    At this point you are ready to exert direct control over any units you 
have defined.    You can either start defining events for the CP290, or start arranging 
units on blueprints of the rooms in your home.    To start defining events, follow the next 
few steps.    To start arranging units on room blueprints, skip down to step 5 below.
See also
Procedures Associated with Units
Creating New Unit Types/Icons
Controlling a Unit via the Units Window

4 Save any events currently in the CP290
If you have been using the CP290, you probably have some events stored in its memory.  
To upload and save these events, follow these steps:
a  Restore the child window called "current events" (by double clicking its icon).
b You will be prompted by a dialog box suggesting you upload with no conditionals.    

Choose OK.
X10MSW uses a portion of the battery-backed-up RAM in the CP290 (called, in CP290 
terms, graphics RAM) to save additional information about events, such as month of 
the year, user conditionals, frozen, etc.    Since your other CP290 control software did 
not use this graphics RAM like X10MSW, this uploads events without reading the 
(garbage) in the graphics RAM.    These events will be active for all 12 months of the 
year, not frozen, etc.    You can save these events to a file (use the Save item under 
the File menu) and edit them later.    If you do a regular upload, some or all of your 
events will not be active (show as grayed text in the event window), and when you 
edit them, the will be scheduled for strange months, conditions, etc.    If this happens, 



you can always do another upload (use the File menu), but be sure to choose the 
"upload with no conditionals" item.

c You can now edit any of these events (or add new ones), and save them to an event 
file, by following Procedures Associated with Events.

See also
Uploading Events
Saving an Event file
Event Conditionals



Units Window Definition
The Units child window displays the collection of icons that represent the units you have 
defined.
Note that this window cannot be closed;    selecting Close from the system menu (or using 
the Control-menu box) will simply minimize the window (much like in Window's Program 
Manager).



Units Window
The Units child window displays the collection of icons that represent the units you have 
defined.    Each unit has a housecode, a unit number, a location, and a description.    Each 
unit also has a type which causes a certain icon, such as a light bulb, a fan, etc. to be 
displayed.    You can define your own unit types and the icons that represent them.    There 
is usually an active unit whose description is highlighted (referred to as selected).
The unit icons are arranged based upon the size of the description.    If you resize the 
window, the icons may move, but their order will be unchanged.    If there are too many 
icons to fit the current window size, scroll bars will appear and you can use those to scroll 
the icons into view, or use the PgDn/PgUp keys.
Note that this window cannot be closed;    selecting Close from the system menu (or using 
the Control-menu box) will simply minimize the window (much like in Window's Program 
Manager).
See also
Procedures Associated with Units

Commands
File Menu
Edit Menu
Direct Menu
AllUnits Menu
Interface Menu
Window Menu



Monitor Window Definition
The Monitor child window allows you to monitor the commands sent by the CP290, either 
direct commands (via X10MSW or keys), or stored events.    Unfortunately, the CP290 
cannot tell X10MSW about commands sent by other X-10 controllers. With the optional PLIX
inteface X10MSW can monitor all X10 commands generated by any console/device in your 
house.    The monitor child window can display CP290 only, PLIX only, or both.    In addition, 
commands received by the PLIX interface can cause a short beep.

Note that this window cannot be closed;    selecting Close from the system menu (or using 
the Control-menu box) will simply minimize the window (much like in Window's Program 
Manager).



Monitor Window
The Monitor child window allows you to monitor the commands sent by the CP290, either 
direct commands (via X10MSW or keys), or stored events.    Unfortunately, the CP290 
cannot tell X10MSW about commands sent by other X-10 controllers. With the optional PLIX
inteface X10MSW can monitor all X10 commands generated by any console/device in your 
house.    The monitor child window can display CP290 only, PLIX only, or both.    In addition, 
commands received by the PLIX interface can cause a short beep.
The Monitor window holds up to 100 commands, each of which is optionally time and/or 
date stamped.    You can scroll back and forth using the scroll bars and/or PgUp/PgDn; and 
also start a log file.    The log file is limited only by available disk space; it does not wrap.
The Monitor window will continue to monitor commands even when minimized.    If you 
scroll the most recent command off the screen, the window will not scroll; otherwise the 
window will scroll down as commands are displayed.
Note that this window cannot be closed;    selecting Close from the system menu (or using 
the Control-menu box) will simply minimize the window (much like in Window's Program 
Manager).
See also
Procedures Associated with Monitoring.
Commands

File Menu
Options Menu
Interface Menu
Window Menu



Current Events Window Definition
The current events child window is a special event window which    reflects the set of events
currently in the CP290.    You can manipulate the events just as you would in an event file.    
The current events window is in one of two modes - immediate or delayed.    When in 
immediate mode, any change you make to an event is immediately made in the CP290.    In
delayed, you must download the set of events to the CP290.
The current events window starts minimized.    When you restore it, an upload from the 
CP290 is done.    If you download the CP290 from another event file, the current events 
window is updated to reflect the new set of events.
Note that this window cannot be closed;    selecting Close from the system menu (or using 
the Control-menu box) will simply minimize the window (much like in Window's Program 
Manager).



Current Events Window
The current events child window is a special event window which    reflects the set of events
currently in the CP290.    You can manipulate the events just as you would in an event file.    
The current events window is in one of two modes - immediate or delayed.    When in 
immediate mode, any change you make to an event is immediately made in the CP290.    In
delayed, you must download the set of events to the CP290.
The current events window starts minimized.    When you restore it, an upload from the 
CP290 is done.    If you download the CP290 from another event file, the current events 
window is updated to reflect the new set of events.
Note that this window cannot be closed;    selecting Close from the system menu (or using 
the Control-menu box) will simply minimize the window (much like in Window's Program 
Manager).
See also
Procedures Associated with Events.
Commands

File Menu
Edit Menu
Options Menu
Interface Menu
Window Menu



Event File Window Definition
Event file child windows allow you to manipulate a set of events and load/store them 
from/to files and/or download them to the CP290.    You can have multiple event file 
windows open at one time, allowing you to easily see the differences between them.    
X10MSW likes to save events to files with extension of .x10, but you could use any 
extension.



Event File Window
Event file child windows allow you to manipulate a set of events and load/store them 
from/to files and/or download them to the CP290.    You can have multiple event file 
windows open at one time, allowing you to easily see the differences between them.    
X10MSW likes to save events to files with extension of .x10, but you could use any 
extension.
To open an existing event file

From the File menu, choose Open Event File
To make a new event file

From the File menu, choose New Event Window
Each Event window has a list box which displays the events in the file.    If you resize the 
window,    the list box changes size with it.    The event list box has a vertical scroll bar but 
no horizontal scroll bar.
See also
Procedures Associated with Events.
Commands

File Menu
Edit Menu
Options Menu
Interface Menu
Window Menu



Procedures Associated with Units
Adding a Unit
Selecting a Unit
Controlling a Unit via the Units Window
Deleting a Unit
Changing a Unit
Creating New Unit Types/Icons
Rearranging Unit Icons
Printing Units Defined



Procedures Associated with Interfacing to the CP290
Selecting COM Ports
Selecting Demo Mode
Activating PLIX Ports
Changing Base Housecode
Setting the Clock
Testing the CP290



Procedures Associated with Monitoring

To change date and/or time stamping:
Use the Options menu item to choose time/date stamping.    A check mark indicates 
what is active.    Time/Date stamping will affect both the display and logging of 
commands sent by the CP290.

To clear the window:
From the Options menu, choose ClearScreen.

To start/stop logging to a file:
Use the File menu to start/stop logging to a file.    When starting, you will get a dialog 
box to select the log file.    If the file exists, you will be asked to confirm overwriting it.    
The full path and filename of the log file is placed in the monitor window title bar.

To control display of CP290 and/or PLIX commands:
Use the Options menu item and check any combination of Show CP290 and/or Show 
PLIX.    A checkmark indicates commands received by that device will be displayed.    
Commands received via the PLIX interface will be prefixed with a "PLIX" string in the 
monitor output.

To cause a short beep when commands are received via the PLIX:
Use the Options menu item and check Beep PLIX.    A checkmark indicates a short beep
will be made whenever a command is received from the PLIX interface.



 File Menu
This menu has several items in common to all child windows, and some items which are 
unique and change with the active child window.    Items in common are:
New Event Window: creates a new event file (and event window)
Open Event File: open an event file (creates an event window)

Exit: exits X10MSW - asks for confirmation if you made any changes.    The size and 
location of the Units, Monitor, Current events, and Blueprint windows are saved and
used next time X10MSW is run.

See also:
File Command Menu - Units Window
File Command Menu - Monitor Window
File Command Menu - Current Events Window
File Command Menu - Event File Window



File Command Menu - Monitor Window
The File menu when the Monitor child window is active has an item which allows you to 
start/stop logging of events.    The menu item changes depending on whether the log is 
open or closed.
See also
Procedures Associated with Monitoring



File Command Menu - Units Window
The File menu when the Units child window is active has an item which allows you to print 
the currently defined units.
See also
Procedures Associated with Units



File Command Menu - Current Events Window
The File menu when the current events child window is active has items which allow you to 
save the current events into an events file, append an events file, upload from the CP290 to
the PC, download a set of events from the PC to the CP290, or print the current events.
See also
Procedures Associated with Events

Saving an Event file
Appending from another Event file
Uploading Events
Downloading Events
Printing an Event file



File Command Menu - Event File Window
The File menu when an event file child window is active has items which allow you to save 
the events into the file they came from or into a different file; open another event file using
the same event window; append another event file to the event file open in this window; 
download this set of events, or print this event file.
See also
Procedures Associated with Events

Opening an Event file
Saving an Event file
Appending from another Event file
Downloading Events
Printing an Event file



Direct Command Menu - Units Window
Allows you to command a unit to turn on, off, dim, bright, fade, or go up.
To issue a direct command
1 Select a unit
2 From the Direct menu, choose the command
For dim and bright via the PLIX, you specify the number of dim or bright commands to send
to the unit rather than the level.
See also
Selecting a Unit
Controlling a Unit via the Units Window
AllUnits Menu



 Edit    Menu - Units Window
Allows you to add, delete, or change unit definitions.    When you define a unit, you supply 
its housecode, unit number, location, and description, and type.    This information is used 
to display a unit in the Units window.
See also
Adding a Unit
Deleting a Unit
Changing a Unit
Note that when there are no units defined, the Del and Change items are not valid.



Edit Menu - Event Window(s)
Allows you to add, delete, or change an event.    If there are no events in the window, delete
and change are disabled.    The standard cut, copy, and paste clipboard operations are 
supported on events.
This menu also allows you to extend your control over which events the CP290 will perform 
by making all events dependent (conditional) on conditions like "Vacation" or any condition 
you define.
Note that if there are no events in the window, only the Add item is valid.
See also
Adding an Event
Deleting an Event
Changing an Event
Defining user-defined Event Conditionals
Specifying Event Conditionals



 AllUnits Menu
Active when the Units window is the active X10MSW window, these commands allows you 
to command all units to turn on, off, dim, or bright to a level you choose, or fade.    Note 
that with the CP290, you will turn all units on, be they lamp or appliance units, which is 
different from other X-10 command consoles which will only turn all lamps on.    There are 
also a set of menu items which allow to command all lamps to turn on, off,    dim, or bright 
to a level you choose.    When using a CP-290, X10MSW uses the lamps you have defined to
know which units to command, so if there is a lamp unit you have not told X10MSW about, 
it will not be affected by this action, which again differs from other X-10 command consoles
when you use "All Lights On".    The PLIX interface fully supports the All Lights On command.
You can command units with the same housecode as the CP290 base housecode, or you 
can specify any other housecode.
See also
Controlling a Unit via the Units Window
Direct Command Menu



 Interface Menu
This command allows you to set the com port (1-4) to which the CP290 is attached. Note 
that the com port you choose is saved in the x10.ini and will be used next time X10MSW is 
run.      This menu also allows you to select demo mode.
You also use this command to change the CP290's base housecode, clock, or run self-tests.
Lastly, you use this command to enable and control automatic downloading of an event file 
based on the time elapsed since your last download.
See also
Selecting COM Ports
Selecting Demo Mode
Changing the CP290 Clock
Changing the base housecode
Testing the CP290
Enabling Auto-download of an Event file



Options Menu - Monitor Window
This menu allows you to turn date and/or time stamping on or off.    You can also clear the 
window, control CP290/PLIX output, and cause a short beep when commands are received 
via the PLIX interface.

See also
Procedures Associated with Monitoring.



Options Menu - Event Windows
Gives you control over how events are sorted; allows you to extend you control over which 
events the CP290 is to perform by defining your own conditionals; allows you to specify 
your latitude and longitude, allows you to specify an offset scale, and, for the current 
events window, allows you to switch between immediate and delayed mode.
See also
Controlling how Events are Sorted
Setting/Resetting Event Conditionals
Defining user-defined Event Conditionals
Setting Latitude/Longitude and Timezone
Specifying an offset scale



Window Menu
This is a standard MDI window menu which allows you to arrange the child windows or 
select the active child window.    Note that the Arrange Icons item does not mean arrange 
the unit icons.This menu also contains items for:
1 Closing all child windows

This causes the Units, Current Events, and Monitor windows to be minimized, and all 
open Event file windows to be closed.

2 Closing all event windows

This menu also contains an item for enabling 3D controls.    These will look best when the 
color of your button faces is something other than white (typically light gray).    Note that 
3D controls are not supported under Windows 3.0.    3D controls use the CTL3DV2.DLL 
which is installed into the Windows system directory.



Adding a Unit
You use the Units window to add new units.
To define a new unit:
1 Activate the Units window
2 From the Unit window's Edit menu, choose Add

- or -
Click anywhere there is no unit icon

3 Choose the housecode
4 Choose the unit number
5 Enter the unit location
6 Enter the unit description
7 Choose the unit type by selecting a type from the list box.    You can see the "on" and 

"off" icons that will be used to represent the unit by selecting a type from the list box.    
As part of this, you may create a new type and/or change the icons.

The ADD button adds this unit, and leaves the dialog so you can add another unit
The OK button adds this unit and exits the dialog
The new unit will be displayed in the Units window, and be selected.    This makes it easy to 
rearrange the new unit's icon in the unit window.    The add dialog starts with a unit number 
that is one greater than the currently selected unit (or the last unit added); and is started 
with the CP290's base houscode.
See also
Creating New Unit Types/Icons
Rearranging Unit Icons



Deleting a Unit

To delete a unit:
1 Select a unit from the Units window
2 From the Unit window'sEdit menu, choose Del

- or -
Use the Del key

3 You will be asked to confirm the deletion of the unit
The first unit in the Units window will be selected.
See also
Selecting a Unit



Changing a Unit

To change a unit:
1 Select a unit from the Units window
2 From the Unit window's Edit menu, choose Change

- or -
Double click the right mouse button on any unit (you do not need to select it first).

3 A dialog similar to that used during adding a unit will display the current unit's 
parameters

4 Make the changes required
5 Either the CHANGE or OK button will make the change
If you change the unit number or housecode to one already defined, you will asked if you 
want to really do that.    If you change only the location, description or type, the icon will not
"move" in the Units window.      Otherwise the icon will move, but you can always rearrange 
the icons.
See also
Selecting a Unit
Adding a Unit
Rearranging Unit Icons



Selecting a Unit

To select a unit in the Units window:

mouse Click on its icon or text.    Note that if not all units are visible in the Units 
window, you can use the scroll bar to scroll the Units window. 

keyboard Use the cursor or tab keys to move from unit to unit.    Note that not all the 
units are visible in the Units window, you can use the PageUp and PageDown 
keys to scroll the Units window.



Selecting COM Ports

To select/change the port to which the CP290 is connected:
1 From the Interface menu, choose COM1-4

The port chosen will be checked.
X10MSW will try to get the base housecode from the CP290 immediately.    If the cable is 
not connected, the com port is not working, the CP290 is not working, you have the com 
ports configured in Windows incorrectly, or some other problem which prevents X10MSW 
from getting the base housecode, you will see a time-out message.    Correct the problem 
and re-select the com port .
The com port to use is changed in the x10.ini file and used by X10MSW next time it is 
started.
See also
Selecting Demo Mode



Selecting Demo Mode

To run X10MSW in demo mode
1 From the Interface menu, choose Demo

Note that if you were actually using a com port, it will be "forgotten" and you 
will have to re-select it.

2  X10MSW will run in demo mode (even if you exit and re-start it) until you select a com 
port.

See also
Selecting COM ports



Changing the base housecode

To change the CP290's base housecode:
1 From the Interface menu, choose Housecode.
2 Choose the new base housecode
Note that changing the base housecode will erase all events stored in the CP290. 
You will be asked to confirm that you really want to do this.



Changing the CP290 clock

To change the CP290's internal clock:
1 From the Interface menu, choose Clock.

The existing CP290 time/day will be displayed.
2 Change the time/day and choose OK.    If you enter the time in 24-hour format, it will    be

converted to 12 hour AM/PM format.
- or -
You may choose the button displaying the system    time/day to sync the CP290 with the 
system clock

Note that in either case, the time will be changed when you choose OK.    If you take a few 
minutes to decide/review your selection, the CP290 clock will be slow.



Activating PLIX Ports

To activate a PLIX evaluation board:
1) From the Interface menu, choose PLIX.
2) Choose LPT1-LPT3 or No PLIX

X10MSW will check that a PLIX evaluation board is connected to the parallel port you 
specify, turn on the power to the PLIX board, and begin to poll for X10 commands received 
by the board.    The LPT port is saved in the x10.ini file and is opened when X10MSW is 
started.

A checkmark is placed next to the LPT port being used for the PLIX board.
If an error has occured when accessing the board no LPT ports will be checked.    X10 MSW 
expects LPT1 to be at (hex) 378, LPT2 at 278, and LPT3 at 3BC.

Choosing No PLIX will turn off the board's power and will stop the opening of a LPT port for
the PLIX board when X10MSW is started.

Note that, if possible, the PLIX board should be powered either via a battery or an AC 
adapter connected via the battery leads rather than the J5 connection.    This allows 
X10MSW to turn off power and reset the PLIX chip to clear any errors.



Testing the CP290

To run the CP290's self-tests:
1 From the Interface menu, choose TestX10.
This takes a few seconds; you will be told whether the tests failed or succeeded.
Note that running self-tests will erase all events stored in the CP290 .    You will 
be asked to confirm that you really want to do this.    If you upload events after a 
self-test, you will see a lot of garbage events.
See also
Uploading Events



Creating New Unit Types/Icons
When adding or changing a unit, you specify a type.    Each type has an "on" icon and an 
"off" icon which is used when displaying the unit in the Units window.    X10MSW has a set 
of pre-defined types and icons that go with them (e.g. lamp, radio, etc.).    You can add your 
own types whenever you add/change a unit, but you must first create one icon to display 
when this type of unit is on, and one for when it is off by using any icon editor to create the 
"on" and "off" icons and save them to separate files.    When you define the new unit type, 
you will give the type a name, the name of the file with the "on" icon, the name of the file 
with the "off" icon, and whether the unit is a lamp (can be dimmed) or appliance.    This 
information is recorded in the x10.ini.    You can also change the icons used when displaying
the pre-defined types (e.g. lamp, radio, etc.), but you will need to change both the "on" and
"off" icons.
The following procedures assume you are in the Add/Change a Unit dialog box.
To define a new unit type:
1  Use the New button.
2 Specify the "on" icon file
3 Specify the "off" icon file
4 Give the type a description
5 Specify whether the type is a lamp or appliance
6 Choose OK
To customize an icon for a type:
1 Select the type from the list box
2 Use the Change button
3 Make changes as required.    Note that if you are changing a pre-defined icon (lamp, 

appliance, misc., coffee, lamppost, radio, or fan) you must change both the "on" and 
"off" icons.

Currently the only way to "delete" a custom icon is to edit the x10.ini file and remove the 
icon description from either the "LampIcon" or "OtherIcon" sections.
If X10MSW finds a unit icon that is unknown, a special icon with a question mark is used to 
represent the unit.
See also
Adding a Unit
Changing a Unit



Controlling a Unit via the Units Window

To turn a unit on or off via the Units window:
mouse Double-click the unit icon. The icon will change to indicate on or off.

keyboard Select the unit and hit enter.    The icon will change to indicate on or off.
To dim, bright, fade, or up a unit, you must use the Direct menu.
See also
Selecting a Unit
Direct Command Menu - Units Window



Rearranging Unit Icons

To rearrange unit icons within the Units window:
Drag the unit icon to where you want it.    You must drag it "on top of" another unit, that 
unit is "pushed over".    Note that the cursor changes when you are dragging a unit icon.
Alternatively, you can:
1 Select a unit
2 Hold down the shift key and click the left mouse button on the unit where you    want the 

selected unit to be moved to
All the units "after" (left to right, top to bottom) the spot you moved the icon to will be 
moved over.
Moving an icon to the last position requires two moves, one to move it to the second-to-last
position, and then selecting the last icon and moving it to the second-to-last position.
See also
Selecting a Unit



Printing Units Defined
Choosing the Print item from the Units window's File menu will produce a short printout of
all the units you have defined.    Information printed includes Housecode, Unit, Location, 
Description, and Type.



Glossary

appliance
base housecode
brightdef_bright
conditionals
days
description
demo mode
dim
event
fade
housecode
lamp
level bar
location
PLIX
normal
security
select
time
today
tomorrow
type
unit
unit number
up
x10.ini





Unit
Each X-10 (or compatible) module, wall switch, etc. is a separate unit.    Each unit has a 
housecode and unit number (1-16) which you set.    Generally, each unit is a different lamp, 
appliance, etc., although you can assign the same housecode and unit number to multiple 
modules, wall switch, etc. and they all get lumped together under one unit.



Housecode
A letter from A to P.    Generally all your units will have the same housecode, although if you
have more than 16 units you will need to use more than one housecode.    Housecodes 
prevent confusion should your neighbor be using X-10 units and command are crossing 
over between houses.



Lamp
A type of unit (wall module or wall switch) which can be used to control incandescent lamps
only.    These units are capable of dimming the lamp and so should not be used with 
appliances.



Lamp Level Bar
Lamp units are displayed with a level bar when the lamp is dimmed to some level.    This 
bar is a dashed box running the width of the icon, and is the thickness of the frame of a 
window which can be sized.    Lamps which have been fully dimmed (PLIX only) will be at 
0%.    Lamps which have been dimmed by the CP-290 will be between 6% and 93%.



Appliance
A type of unit (wall module) which can be used to control appliances, lamps, etc.    These 
units are not capable of dimming.    They contain a latched relay which during a power 
failure will stay in their previous "state" (on or off).



Unit Number
A number from 1 to 16 which is set on each unit.    Commands to control a unit (turn it on, 
off, etc.) always contain a unit number which specifies which unit to control.



Description
A text string which describes what a unit is controlling.    Try to avoid using words like lamp, 
appliance, etc. since the unit's icon will tell you that.    It should not be too long or the icon 
will take up too much room in the main window.    This can never be longer than 64 
characters.    See also unit Location.



Location
A text string which describes where a unit is, typically a room in your home, e.g. Living 
room.    It should not be too long or the icon will take up too much room in the unit window.  
This can never be longer than 64 characters.    See also unit Description.



Type
Each unit has a type.    X10MSW has a bunch of pre-defined types such as lamp, appliance, 
fan, radio.    You can also define your own types and icons to go along with them by using 
any icon editor to create an "on" icon and a "off" icon..    You can specify new icons for the 
pre-defined types too, although you must specify both an "on"    and "off" icon.    Only lamp 
type units can be dimmed.



Base Housecode
The CP290 has a base housecode which is used when you depress the keys on top.



Dim
A lamp unit can be dimmed to one of 16 (0-15) levels, with 0 being the brightest and 15 the
dimmest.    X10MSW uses hexadecimal notation (10-15 is a-f) so that accelerators can be 
used to specify the dim level for the CP-290 or the number of dim commands to send to the
unit when using a PLIX interface.    In general, a lamp unit's level is displayed as a 
percentage (0 being dimmed off, 100 being fully bright).
NOTE:    The CP-290 will set a lamp's level by fully brightening it, and then 
dimming it to the desired level.    This is (obnoxious) behavior that X10MSW 
cannot control.    The CP-290's lowest dim level is 6%.

The PLIX is capable of dimming a unit fully off, which is displayed as a level of 0%.    When 
in this condition, a lamp module will respond to a PLIX bright command by simply 
brightening the lamp.    When a lamp module is off, it responds to a bright command (PLIX 
or any command console) by turning the lamp on fully.



Up
This undocumented CP290 command causes an "All Lights Off" X-10 command followed by 
several bright commands to the selected unit.    The "All Lights Off" command is not 
standard and is not obeyed by all X-10-compatible modules.



Fade
This command will turn any unit off.    Lamp units are dimmed to fully off, appliance 
modules are switched off.    This is not documented in the CP290 documentation but seems 
to work very reliably.



Bright
This command will cause a lamp unit to increase in brightness.    If it is currently off it is 
turned fully on.    This is supported only when using the PLIX interface.    Like the PLIX dim 
command, you specify the number of bright commands to send to the unit.    The PLIX is 
capable of dimming a unit fully off, which is displayed as a level of 0%.    When in this 
condition, a lamp module will respond to a PLIX bright command by simply brightening the 
lamp.    When a lamp module is off, it responds to a bright command (PLIX or any command 
console) by turning the lamp on fully.



x10.ini
This file contains all the unit information in "Windows" format.    It must be in your windows 
directory. You can edit it manually, the format should be pretty easy to figure out.



Selected
When a unit is selected, its housecode/unit number and description are highlighted.    The 
color used for the background follows the active title bar background.



Demo Mode
When X10MSW runs in demo mode, no com port is needed, and no CP290 is needed.    
Almost all actions are simulated; exceptions are:
1 you cannot download an events file (you can save to a file)
2 upload causes the file current.x10 to be opened and read
3 changes to base housecode are not remembered



Event
An event tells the CP290 to control some unit at some time on some day(s).    Events are 
stored in the CP290's battery backed-up memory and executed by the CP290 at their 
appointed time on their appointed day(s).    Each event can cause one command, such as 
on, off, dim, etc.    Each event can control up to 16 units, but they must all have the same 
housecode.



PLIX Interface
X10MSW supports a PLIX evaluation board from Micromint Inc.    which uses a standard 
parallel printer port (LPT1-3) to interface to a TW523 bi-directional powerline interface from
X10 USA.    This allows X10MSW to monitor all X10 commands and to issue "bright" 
commands (which the CP290 does not support).      X10 commands received via the PLIX will
update the status of the unit(s) affected.    The TW523 does not send every dim or bright 
command being sent on the power lines to the PLIX, so X10MSW has to do some 
interpolation.    If a lamp unit's level is adjusted by many dim/bright/dim/bright/etc cycles, 
the dim level displayed by X10MSW will probably not be accurate.
The PLIX interface is used for on, off, dim, bright, all lights on, and all units off commands 
either direct or via now events.

The PLIX evaluation board and TW523 can be ordered from:
          Micromint Inc
          4 Park Street
          Vernon, CT    06066
          (203) 872-2204

For best operation, use the PLIX evaluation board with a battery or an AC adapter which 
connects via the battery leads rather than via the J5 connection.



Procedures Associated with Events
All about Events
Working with Current Events
Opening an Event file
Creating a New Event file
Specifying an Event (the Event Dialog Box)
Adding an Event
Deleting an Event
Changing an Event
Using the Clipboard
Appending from another Event file
Saving an Event file
Downloading Events
Uploading Events
Closing an Event window
Controlling how Events are sorted
Defining user-defined Event Conditionals
Setting/Resetting Event Conditionals
Setting Latitude/Longitude and Timezone
Printing an Event File
Enabling Auto-download of an Event file
Specifying an offset scale



All about Events
Events are stored in the CP290's memory and used to control units (turn some on, some 
off, etc.) at    the times and on the days you want.    This is done completely by the CP290, 
the PC does not have to be on (if it is the CP290 tells X10MSW when it does an event - you 
can see these in the Monitor window).    The CP290 can hold a maximum of 128 events.
Each event consists of the following parts:

Info. stored and used by the CP290:
1 Housecode
2 One or more units
3 A command:    on, off, dim, up, or fade
4 A time (more about this below)
5 A day or set of days
Extra info. stored and used by X10MSW:
6 Time "qualifiers" like now, sunset, sunrise, etc.
7 Event conditionals like months, frozen, vacation, and
8  up to 8 user-defined conditionals 
The "extra" info. is used by X10MSW to determine if a particular event should be 
downloaded to the CP290, or if the time should be calculated by X10MSW before it is 
downloaded.    An event which X10MSW determines should not happen is still downloaded 
to the CP290, but it is scheduled to occur on no days.    This way, the current events window
has all the events you have specified.    This "extra" info is saved in a part of the CP290's 
memory called "graphics RAM", and is unique to X10MSW.
Events are displayed in a list box in event windows.    Events can also be saved in event 
files, which X10MSW likes to give an extension of .x10.
See also
How Events Are Displayed
Event Dialog Box



Event Dialog Box
The event dialog is used whenever you are adding or changing an event.    It is a pretty 
busy dialog.    Listed below are the things you will want to do with the event dialog in order 
to get events to be the way you want them:

Specifying Event Housecode and Unit(s)
Specifying Event Days
Specifying Event Times
Specifying Event Conditionals

Use the OK button to add/change the event
When adding, use the Add this.... button to add this event and keep the dialog going for 
another new event.    If the previous command turned the unit(s) on, this event will turn the 
unit(s) off, or vice versa.
When changing, use the Change this.... button to change this event and keep the event 
dialog going (see above).    The button will change to Add this....
If you use the Add this... or Change this... button with a current event and the mode is 
immediate,    the event will be downloaded.
See also
Adding an Event
Changing an Event



Specifying Event Housecode and Unit(s)

To specify which unit or units will be affected by an event:
1 Drag a unit icon from the units window into the event window.

- or -
Use add/change event to start the event dialog box
When you are adding an event, the housecode/unit are initially set to whichever unit is 
selected in the Units window.

2 Use the drop-down list box in the upper-left corner to select a defined unit
- or -
Select a housecode

3 Select a unit.    To select multiple units, hold down the shift key and click/select each unit 
you want affected by this event - either by using the unit radio buttons or by clicking one
of the units in the drop-down list box (all must be the same housecode).
- or -
Use the All Units button to select all units for a housecode.



Event Time and Time Qualifiers
Ultimately, each event is scheduled by the CP290 to occur at some time.
Events that occur on some day of the week (not Today or Tommorow) can be in security 
mode, which causes the CP290 to vary the actual time the command occurs in a pseudo-
random pattern.    The actual time will be within one hour after the time specified in the 
event.
Event times may take one of the following forms:
1 A specific hour/minute, AM or PM
2 NOW - just what it means.    These events are not downloaded but done via the CP290's 

direct command capability.    Each NOW event is counted towards the 128 event limit per 
event file/download.

3 Sunrise, or a +/- 59 minute offset from sunrise (extended by offset scale)
4 Sunset, or a +/- 59 minute offset from sunset (extended by offset scale)
Sunrise and Sunset are calculated based on your Latitude/Longitude.    Note that when you 
download events you can tell X10MSW to not recalculate sunrise/sunset, otherwise these are 
recalculated each time you download.    Also, the event times displayed in the current events 
window can be either the time which would be used if the event were download, or the actual 
time stored in the event in the CP290.



Security mode
An event which uses security mode causes the CP290 to vary the actual time an event 
occurs within one hour after the scheduled event time in a pseudo-random fashion.



Normal mode
An event which uses normal mode causes the CP290 to perform the event at the time 
scheduled.



Offset and offset scale
The offset and offset scale let you tie events to sunrise and sunset.    You can use a different
offset in each event; the offset scale is used for all events in all event windows.    The offset 
in minutes is the offset you've defined in the event multiplied by the offset scale.    The 
offset scale extends the range of the offset, but decreases the granularity.    An event offset 
is always limited to +/-59.    With a offset scale of 1, this gives +/-59 minutes, with a 
granularity of 1 minute.    With an offset scale of 5, the offset is +/-295 (+/-59 * 5) minutes, 
with a granularity of 5 minutes.
You specify an offset when adding or changing events.    To specify the offset scale, from 
any event window's Option menu, choose Set Offset Scale.



How Events Are Displayed
Events are displayed in a list box in each event window.    Events which are inactive 
because of one or more false conditionals are displayed in gray text if your display supports
gray text, otherwise the event is prefixed with an exclamation mark (e.g. on CGA displays).
There are several sorting options which affect what is displayed first and hence how events 
are sorted, but a typical event is displayed as:
HU+ [Loc][Desc] CMD HH:MM isxx    MTWTFSS Months FV12345678
Where:
HU is Housecode and Unit.    If the event has multiple units, each is displayed on a different 
line with the "+" indicator.
Loc is the unit's location from the Units window.    If the event has multiple units, the 
description is for the unit with the smallest unit number.
Desc is the unit's description from the Units window.    If the event has multiple units, the 
location is for the unit with the smallest unit number.
CMD is one of:      On        Off      DimX (X is 6-93%)    Fade    Up.    If the command is prefixed by
a hyphen, it means that the current event in the CP290 would change if you did a download
of the current events window right now.    For example, if the event in the CP290 was active 
only in January and the current month is not January, then the command will be prefixed by
a hyphen.    This usually means you need to download either the current events or the 
event file which was previously downloaded.
HH:MM is hour and minute in 12-hour format, i is A for AM and P for PM

- or -
Now for a direct command.    Note that the current events list box never contain any direct 
commands since they are not stored in the CP290 and are only done when an event file is 
downloaded.
s is S for Security mode, nothing for Normal mode
xx is:

Nothing for normal time
sr for sunrise with optional +/- offset (1-59)
ss for sunset with optional +/- offset (1-59)
Note that for times with an offset, just the offset (1-59) is displayed, but the effective 
offset (offset * offset scale) is reflected in the HH:MM displayed.
Note that the actual time which will be downloaded is in HH:MM    For event files, this is 
calculated when the file is opened.    For    current events, you can have either the 
calculated time (the time which would be download if you did a download) displayed, or 
have the actual time defined in the event currently in the CP290 displayed; See Choosing
how current event times are displayed.

MTWTFSS indicates days of the week, or one of:
Everyday
Weekdays
Weekend
Today
Tomorrow

Months (JFMAMJJASOND) indicates months of the year, or one of:
All Year



Winter
Spring
Summer
Fall

FV12345678 indicates any active conditions, such as:
F for frozen
V for vacation
1-8 for the 8 user-defined conditions

See also
Procedures Associated with Events
Event Conditionals
Contolling how Events are Sorted
Specifying an offset scale
Downloading Events
Choosing how current event times are displayed
Defining user-defined Event Conditionals



Specifying Event Times in an Event Dialog

To specify a time for an event:
1 Add or change an event to start the event dialog box
2 Use the time qualifier list box (near the HH:MM and AM/PM button) to select one of:

- As displayed (no qualifications to the time displayed)
- Now    - the days scheduled will still apply.
- Sunrise with optional +/- offset
- Sunset with optional +/- offset
Note that offsets are limited to 1-59, and can be extended by using the offset scale.    
Both the offset (+/-59) and the effective offset (offset * offset scale) are displayed.
Also note that you cannot specify a Now event in the current events window

3 Use the buttons with numbers to select the hour, the minutes "tens", and minutes 
"ones".    

4 Use the AM/PM button as required
5 Specify security or normal mode
6 Note that security/normal does not apply to events which occur    Today or Tomorrow.
See also
Specifying an offset scale
Adding an Event
Changing an Event



Event Days
An event can be scheduled for any day of the week, Sunday through Saturday.    An event 
can also be scheduled for Today or Tomorrow;    these happen only once and then are 
deleted by the CP290 once they are executed.



Now (immediate) events
Now events are not downloaded but done via the CP290's direct command capability.    
They may be affected by event conditionals and by any day of the week.    They count 
towards the 128 event limit in event files.



Today or Tomorrow events
Events scheduled for Today or Tomorrow occur only once at the time specified.    The CP290 
deletes the events after they have been executed.
These types of events are always in normal mode.



Specifying Event Days in the Event Dialog

To specify on which day(s) the event will occur:
1 Add or change an event to start the event dialog box
2 Select the days of the week as required

- or -
Use the shortcut buttons for everyday, weekdays, or weekends
- or -
Use the Today/Tomorrow buttons.    These types of events are forced into normal mode, 
and cannot be Now events.

See also
Adding an Event
Changing an Event



Event Conditionals
Event conditionals extend your ability to control when and if an event should be performed 
by the CP290.    The CP290 handles simple conditions like time, day.    X10MSW extends 
these by using event conditionals to determine if an event should occur.    If it should, it is
downloaded as normal to the CP290.    If not, it is downloaded to occur on no days, meaning
the CP290 will never perform the stored event.
The following event conditionals are supported:
1 Month(s) of the year
2 Frozen events which do not occur until you "thaw" them
3 Vacation
4 up to 8 user-defined conditions which allow you to build up your own conditions.    This

allows you to specify, for example, which events you want to happen only when you 
have guests staying with you by defining (a user-defined) conditional called "guests".

Events whose event conditionals make them inactive are displayed in gray text in event 
windows (or prefixed with an exclamation mark for displays that cannot display gray text 
such as CGAs).



Specifying Event Conditionals
You can specify conditions for a specific event when you add or change it, or you can add or
strip a conditional for all events in an event window.
To specify conditionals for a specific event:
1 Add or change an event to start the event dialog box
2 Check the box(es) for the conditionals you wish to apply:

- Frozen events never occur until they are un-frozen (thawed?)
- Vacation
- User-defined conditionals
- Months of the year - you can use the shortcut buttons, which are "additive"

To add or strip conditionals for all events in a window:
1 Activate the event window
2 From the event window's Edit menu, choose Global Cond Set or Global Cond Strip

The user-defined conditionals are listed as "User1 - User8"; the drop-down menu does 
not have the conditional names.
The numbers 1-8 correspond to the numbers displayed in the dialog box used to 
define/set/reset conditionals (See Defining user-defined Event Conditionals).
Note that you cannot globally set or strip conditions in the current events window when it
is in immediate mode.

3 Choose the conditional you which to add/strip.    Note that you can choose a conditional 
which has no name defined.

See Also:
Adding an Event
Changing an Event
Setting/resetting Event Conditionals
Defining user-defined Event Conditionals
Working with Current Events



Setting/resetting Event Conditionals
You can set or reset conditions which will affect events with conditionals.    This gives you a 
lot of control over your events, and extends the CP290's basic time/day capabilities.    The 
conditions which you can set/reset are:

Vacation
user-defined conditions

To set or reset an event conditional:
1 Select any event window
2 From the Options menu, choose Set Conditionals
3 To set a condition, check its checkbox; to reset, uncheck it.
The conditional is set/reset for all event windows.    Its state is stored in the x10.ini file.    
Note that just because you change a condition, it does not mean the CP290 knows about 
it.    You must do a download in order for the change in conditions (and hence change in 
which events are now active or inactive) to take effect.
If you change conditions without doing a download, you will prompted when you try to 
close the event window.
See Also:
Defining user-defined Event Conditionals
Download Events



Defining user-defined Event Conditionals
The CP290's ability to perform stored events based on time and day is great, but X10MSW 
extends your control by allowing you to define conditions of your own, make events 
"conditional" on them, and set or reset these conditions to control which events are active 
or inactive.    A good example of a user-defined event conditional is "Guest Present".    Once 
you've defined a condition with this name, you can add some events which will be done by 
the CP290 only when you have guests.    To activate these events, you would
1 Use the Option menu to Set Conditionals and tell X10MSW guests are present
2 Do a download to activate events which depend on that condition
But first, you have to define this condition called "Guest Present".
To define or change a user-defined event conditional:
1 Activate any event window
2 From the event window's Options menu, choose Set Conditionals
Each conditional has an edit box for its name, and a checkbox to make the condition "true" 
or "false".    To delete a conditional, just clear out its name.
If you delete a conditional and some event in the active event window is dependent on the 
conditional you will be notified.    You may want to use the Global Condition Strip item 
from the Options menu to remove any dependencies.    Note that other event files may still
have this dependency so you should think carefully about deleting user-defined 
conditionals..
The conditionals are stored in the x10.ini file.
See also:
Setting/resetting Event Conditionals
Specifying Event Conditionals
Download Events



Opening an Event file

To open an Event file:
1 Use the File menu in any window
2 Select Open to open a file into a new event window

- or -
Select OpenAnother to open a file into the currently active event window.    If you have 
made changes to the event file, you will be asked to confirm abandoning the changes.

3 Use the dialog box to select a file to open
Note that if you change directories, you can tell X10MSW to remember the directory for 
next time it is started by using the checkbox in the dialog box.
You will get an error message if the event file is corrupt or not readable.
If the Open is successful, a new Event window will be displayed with the name of the file in
the title bar and the events displayed in a list box.    If the OpenAnother is successful, the 
Event window title bar will be changed to reflect the new open file, and the list box will 
contain the events from that file.
See also
Appending from another Event file
Saving an Event file
Closing an Event window



Adding an Event

To add a new Event:
1)Drag a unit icon from the units window into the event window

- or -
Use the Edit menu in any event window, followed by the
Add item

You will get an event dialog box to specify the event.
After exiting the event dialog box, the event you added will be selected in the list box.
When in the event dialog box, you can use the Add button to add an event and keep the 
dialog box going for another new event.    The command will toggle between on and off.
If you add a current event and the current events window is in immediate mode, the 
change will be made immediately.
See also
Specifying an Event (the Event Dialog Box)
Working with Current Events
Appending from another Event file



Deleting an Event
To delete an event:
1 Select an event in the list box
2 Use the Del key or the Edit menu
Don't forget that an event which affects multiple units will be displayed as multiple lines in 
the list box (these have a + after the housecode/unit).    When you delete any of the lines 
that make up an event, that entire event is deleted.    If you want to remove a particular 
unit from that event, change the event.
If you delete an event in the current event window and it is in immediate mode, the change
will be made immediately.
See also
Working with Current Events
Appending from another Event file



Changing an Event

To change an event:
1 Double-click the event in the list box you wish to change

- or -
Use the Change item in the Edit menu

You will get an event dialog box to change the event. If possible, the event you changed will
be selected upon return from the event dialog box.
When in the event dialog box, you can use the Change button to change an event and 
keep the dialog box going for another new event.    The command will toggle between on 
and off,    and the Change button will change to Add.
If you change an event in the current event window and it is in immediate mode, the 
change will be made immediately.
See also
Specifying an Event (the Event Dialog Box)
Working with Current Events



Using the Clipboard
The standard clipboard functions (Cut, Copy, Paste) can be used in any event window.    The
functions have standard accelerator keys.    Events are put into the clipboard in a private 
format and so cannot be edited by other Windows applications.



Appending from Another Event file

To append from another Event file:
1 Use the File menu in any event window
2 Select the Append item
3 Select the event file you wish appended
Note that you cannot append to the current events window in immediate mode.
Don't forget about the limit of 128 events (including now events) per event file and that the
CP290 cannot hold more than 128 events.
See also
Working with Current Events



Saving an Event file

To save an event file:
1 Use the File menu in any event window
2 Select either Save to save the events to the same file as is displayed in the event 

window title bar
- or -
Select Save As to save the events into a file with a name you specify.

Note that the current event window only allows the Save As operation.
If you change directories as part of specifying the file name, you can tell X10MSW to 
remember the directory for next time it is started by using the checkbox in the file Save 
dialog.
If, when using Save As, you specify a file name that already exists, you are asked to 
confirm you want to overwrite the file.

The event window size, location, and options are saved in the event file and restored when 
you open the event file.
See also
Opening an Event file
Closing an Event window



Creating a New Event File

To create a new event file:
Use the New item of any window's File menu.
The new event window will be given a title of Untitled.    Both the Save and Save As 
menu items act as Save As when you go to save the events.
See also
Appending from another Event file
Saving an Event file
Closing an Event window



Downloading Events

To download a set of events to the CP290:
1 Use the File menu in any event window
2 Use the Download item - X10MSW will recalculate any time(s) like sunrise, sunset, etc.

- or    for the current event window you may -
Use the Download - no sun recalc. to download without recalculating any time(s) like 
sunrise, sunset, etc.

A dialog box is displayed during the download allowing you to see the progress of the 
download and to stop the download.    The keyboard/mouse is disabled when the mouse is 
within in the X10MSW window during a download.
Upon completion of a download from any event file window (not the current events 
window), the current events window is updated to reflect the events downloaded.
See also
Uploading Events



Uploading Events

To upload a set of events from the CP290:
1 Select the current events window
2 Use the File menu
3 Select the Upload item

    - or -
Select the Upload - no conditionals item to upload events without any of the X10MSW-
unique conditional information like months, frozen, vacation, etc.    This is useful when 
you are uploading for the first time after using some other X-10 software.    The events 
uploaded are forced to have all month conditionals on and all user-defined conditionals 
off.

A dialog box is displayed during uploading and shows you how the upload is progressing.    
The keyboard/mouse is disabled when the mouse is within the X10MSW window during the 
upload.
See also
Downloading Events



Controlling how Events are Sorted
Events can be sorted by:

housecode/unit first, and then by event time (the default),
housecode/unit first, and then by event command (on comes before off),
or with the time first.

To change how events are sorted:
1 Use the Options menu in any event window
2 Choose the sort option you want
The sort option takes effect in that event window only.    The option is saved in either the 
event file or for the current event window in the x10.ini file, and is restored the next time 
the event window is opened.



Setting Latitude/Longitude and Timezone
In order to calculate the time of day for sunrise and sunset, X10MSW must know your 
latitude and longitude.    These are available from almanacs, maps(?), etc.
X10MSW also calculates whether daylight savings is in effect via the TZ environment 
variable.    This has the format    TZ=zzz[+/-]d[d][lll] where zzz is a three-character string 
representing the name of the current time zone,    [+/-]d[d] is a required field containing an 
optionally signed number with 1 or more digits specifying the local time zone's difference 
from GMT in hours, and [lll] is an optional three-character string which, if present, indicates 
that standard US daylight savings applies.    TZ defaults to EST5EDT.
To specify your Latitude and Longitude:
1 Use the Options menu in any event window
2 Select the Specify Lat/Long item

Use the edit boxes to specify the values in degrees (only minutes, no seconds).
Use the ReCalc button to recalculate and show the various times

3 Use the OK button to actually change the values.
The values for Latitude and Longitude are saved in the x10.ini file.    X10MSW comes with a 
file (latlong.dat) which contains the latitude and longitude of major cities around the world. 
You can use your favorite editor or Windows Notepad to search the file.
To specify that daylight savings does not apply:
Before starting Windows, set a TZ environment variable (See your DOS manual) which does
not have the [lll] part described above, e.g. EST5.



Working with Current Events
The current events window is meant to always reflect the current contents of the CP290's 
RAM.    It starts out minimized and uploads the contents of the CP290 when it is first 
restored.    The current events window is pretty much like other event file windows, with the
following differences:

It is only in the current events window that you can upload events from the CP290.
The current events window can send any changes/additions you make immediately or 
you can make all the changes at once (called a download).
When you download another event file, the current events window is updated to reflect 
the contents of the CP290.
You cannot close the current events window (you can minimize it).
Direct commands (now events) are not stored in the CP290 since they are done during 
download and then do not need to be remembered, so the current events window will 
never have direct command (now) events.
The event times displayed in the current events window are (by default) the times that 
would be download, i.e. sunrise and sunset is calculated when you uploaded.    You can 
choose to have the actual time currently in the CP290's event displayed.

To select that changes be sent to the CP290 as you make them:
From the Options menu of the current events window, choose Immediate Mode.    This 
will be recorded in the x10.inifile.

To select that changes not be sent to the CP290 as you make them:
From the Options menu of the current events window, ensure Immediate Mode is un-
checked.

See also
Downloading Events
Uploading Events
Choosing how current event times are displayed



Closing an event window

To close an event window:
1 Use the File menu of any event window except current events
2 Choose the Close item

If you have made any changes to an event file and have not saved them to a file or have 
made changes to the current events window and not downloaded them, you will be asked 
to confirm abandoning the changes.    If you want to save the changes, answer No and save
the events (when closing an event file window) or download the events (when closing the 
current events window).
See also
Saving an Event file
Downloading Events



Printing an event file

To print an event file or the current events:
1 Use the File menu of any event window including current events
2 Choose the Print item
The printed output includes:

The name of the event file and current date/time
Any user-defined conditionals, and the "vacation" state
All events, double spaced.    Inactive events are prefixed with an exclamation point; these
would be displayed in gray text on a display that supports gray text output.

See also
How events are displayed



Specifying an offset scale
The offset scale allows you to extend the range of offsets from sunrise and sunset, but with 
a decrease in granularity (or resolution).    It applies to all event files, and is not "stored" in 
an event file.    Only the event offset is stored in the event file.
To specify an offset scale:
1 Use the Option menu of any event window including current events
2 Choose the Set Offset Scale item
The minimum (and default) value is 1, the maximum value is 10.



Choosing how current event times are displayed
The event times displayed in the current events window are, by default, the times that 
would be downloaded.    You can choose between displaying these "calculated" times and 
the actual times in the CP290's event by:
1 Use the Options menu of the current events window
2 Choose either of the Show actual event times or Show calculated event times 

items
The title bar of the current events window will change to reflect how the event times are 
being displayed.    The option is saved in the x10.ini file, and restored next time X10MSW is 
started.



Immediate Mode
Any changes made to events in the current event window will be sent to the CP290 
immediately.    If you have only a few changes to make, this will be faster than having to 
download the entire set of current events.



Delayed Mode
Any changes made to events in the current event window will be made inside X10MSW 
only.    You must download the current events to the CP290 in order for the changes to take 
effect.




